Portal performance issue affecting small subset of users

Incident Report for Catchpoint Systems Services Page

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 27, 2026 - 17:54 EDT

Identified

We are currently investigating an issue affecting the Portal affecting a very small subset of our users.

We are working with our Engineering team to resolve the issue.
Posted Aug 27, 2026 - 15:36 EDT
This incident affects: Portal.